Degraded check processing performance
Incident Report for Onfido
Resolved
Check processing delays have subsided at 14:50 UTC.
Sorry for the delay in updating the status.
Posted Feb 17, 2021 - 17:35 UTC
Monitoring
Check processing performance has some delays. We will provide a new update at 15:00.
Posted Feb 17, 2021 - 14:10 UTC