Processing delays for Right to Work checks
Incident Report for Onfido
Resolved
This incident has been resolved.
Posted Jan 07, 2019 - 19:47 UTC
Identified
The issue has been identified and we're working to resolve it.
Posted Jan 07, 2019 - 19:03 UTC
Investigating
We are currently investigating an issue which is causing us to experience extended processing times for Right To Work checks. We will update this status within the hour.
Posted Jan 07, 2019 - 18:00 UTC