Increased Turnaround Time
Incident Report for Onfido
Resolved
We have confirmed that the issue that was causing increased turnaround times for checks that go through manual has been resolved.
Posted Nov 22, 2021 - 15:30 UTC
Monitoring
We have released a fix and are monitoring.
Posted Nov 22, 2021 - 14:14 UTC
Identified
This issue relates to a problem that is impacting manual processing by our BPOs who are using the newly released Chrome 96 version. We are working on a fix.
Posted Nov 22, 2021 - 11:47 UTC
Update
We are continuing to investigate this issue.
Posted Nov 22, 2021 - 11:31 UTC
Investigating
We are currently investigating reports of increased general turnaround time. We will provide an update soon.
Posted Nov 22, 2021 - 10:03 UTC