Check processing delays
Incident Report for Onfido
Resolved
This issue is now resolved.

Checks are now being processed normally.
Posted May 20, 2020 - 15:37 UTC
Monitoring
We have identified the problem and implemented a fix for this issue.

We are monitoring closely to make sure issue has been resolved and everything is working as expected. Please bear with us, we appreciate your patience during this incident.

We'll provide an update at 15:30UTC
Posted May 20, 2020 - 15:14 UTC
Identified
We have identified the underlying issue and took the necessary actions to mitigate it. The issue is only affecting document checks. Next update at 15:10UTC
Posted May 20, 2020 - 14:54 UTC
Investigating
We are currently investigating check delays issue. Next update at 14:40UTC
Posted May 20, 2020 - 14:23 UTC