UK credit check processing
Incident Report for Onfido
Resolved
UK credit check issues have now been resolved. We will re-run the checks that were affected during this time period.
Posted 12 months ago. Nov 29, 2017 - 10:40 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 12 months ago. Nov 29, 2017 - 10:25 GMT
Identified
We're currently experiencing issues affecting the timely processing of UK credit checks.

We're working through this issue with our partner and hope to resolve as soon as possible.
Posted 12 months ago. Nov 28, 2017 - 22:02 GMT