Partial outage for Watchlist reports

Incident Report for Onfido

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 15:49 UTC

Monitoring

The issue has been fixed, and the reports are being processed correctly. We are still monitoring the service.
Posted Jun 06, 2026 - 15:05 UTC

Identified

We identified the issue and are implementing a fix.
Posted Jun 06, 2026 - 14:36 UTC

Investigating

Some Watchlist search search profiles are not working correctly the impacted reports are not being processed. We are investigation the root cause.
Posted Jun 06, 2026 - 14:08 UTC
This incident affected: USA (us.onfido.com) (Watchlist) and Europe (onfido.com) (Watchlist).