Increased latency on check processing
Incident Report for Onfido
Resolved
This incident has been resolved.
Posted Mar 03, 2024 - 18:13 UTC
Monitoring
We implemented a fix and processing latency is back to normal.
We are monitoring closely until all the backlog is processed.
Posted Mar 03, 2024 - 13:57 UTC
Investigating
We are currently investigating this issue.
Posted Mar 03, 2024 - 13:36 UTC
This incident affected: USA (us.onfido.com) (Document Verification), Canada (ca.onfido.com) (Document Verification), and Europe (onfido.com) (Document Verification).