Delays on Dashboard

Incident Report for Onfido

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 13:46 UTC

Identified

We accumulated a large backlog of messages to update OpenSearch and we are currently processing it. The backlog should be cleared in the next hours.
Posted Dec 09, 2025 - 13:33 UTC
This incident affected: Europe (onfido.com) (Dashboard).