QES tasks cannot complete because our provider is encountering issues.

Incident Report for Onfido

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 03:49 UTC

Monitoring

The issue has been fixed. We're monitoring and resuming blocked QES tasks, if they can be.
Posted Jun 23, 2026 - 03:45 UTC

Update

Our provider is still experiencing issues. All QES tasks cannot complete for now.
Posted Jun 23, 2026 - 03:20 UTC

Identified

Our provider is experiencing issues. All QES tasks cannot complete for now.
Posted Jun 23, 2026 - 02:57 UTC

Investigating

We cannot complete QES tasks because our electronic signature provider is encountering issues.
Posted Jun 23, 2026 - 02:38 UTC
This incident affected: Europe (onfido.com) (QES).