Issues with instant checks
Incident Report for Onfido
Resolved
The issue with instant checks found and fixed.
Posted about 1 year ago. Oct 23, 2017 - 19:09 BST
Investigating
We are currently facing issues with instant checks for various services and are currently investigating.
Posted about 1 year ago. Oct 23, 2017 - 18:33 BST