Identity report is experiencing increased TaT (excluding UK, US applicants)

Incident Report for Onfido

Resolved

This incident has been resolved
Posted Sep 02, 2025 - 01:40 UTC

Update

One of our third-party providers continues experiencing technical difficulties. Applicants from locations outside of US and UK are facing increased Turnaround Times (TaT)
Posted Sep 01, 2025 - 22:59 UTC

Identified

One of our third-party providers is experiencing technical difficulties. This impacts Turnaround times of our Identity reports.
Posted Sep 01, 2025 - 22:20 UTC
This incident affected: USA (us.onfido.com) (Identity Enhanced) and Europe (onfido.com) (Identity Enhanced).