Identity report with increased TaT for USA jurisdiction
Incident Report for Onfido
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 10:42 UTC
Monitoring
Found the root cause. TaT are back to normal.
Posted Mar 01, 2024 - 10:24 UTC
Investigating
We are currently investigating the issue.
Posted Mar 01, 2024 - 10:16 UTC
This incident affected: Europe (onfido.com) (Identity Enhanced).