Deterioration in QES product

Incident Report for Onfido

Resolved

Our provider has restored full service now.
QES processing back to normal.
Posted May 08, 2025 - 16:35 UTC

Update

QES requests are being processed again now.
We continue to monitor the situation.
Posted May 08, 2025 - 16:26 UTC

Update

QES processing is starting to come back now. We are continuing to monitor the situation.
Posted May 08, 2025 - 16:21 UTC

Monitoring

We are monitoring our 3rd party provider as they deal with the underlying issues
Posted May 08, 2025 - 16:15 UTC

Identified

The issue has been identified with our 3rd party provider
Posted May 08, 2025 - 16:14 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2025 - 16:04 UTC

Investigating

The QES product is currently down. Due to 3rd party provider.

We are currently monitoring the situation as it develops with our provider
Posted May 08, 2025 - 16:01 UTC
This incident affected: Europe (onfido.com) (QES).