Qualified Electronic Signature failures

Incident Report for Onfido

Resolved

This incident has been resolved. QES tasks are being processed as normal.
Posted Sep 02, 2025 - 23:38 UTC

Monitoring

The maintenance is over. Service has resumed.
Posted Sep 02, 2025 - 23:22 UTC

Identified

Our third-party provider is performing maintenance. All Qualified Electronic Signature capture tasks are stuck in progress. Potential interruption expected up until 00:00 UTC
Posted Sep 02, 2025 - 22:00 UTC
This incident affected: Europe (onfido.com) (QES).