This issue is now resolved: Increased document report TaT in the EU cluster.
A modest number of the queued manual reports remain and are expected to be cleared soon.
We take great pride in running a robust and reliable service, and we're working hard to ensure this does not happen again. A detailed postmortem will follow once we've concluded our investigation.
Posted Sep 24, 2025 - 17:29 UTC
Update
The fix has proven to be effective, and we are now processing live document reports within the expected TaT, given that processing is automatic-only. For document reports that require manual processing, we are clearing the backlog as quickly as possible and hope to return to normal TaT within the next 3 hours.
Please bear with us while we get back on our feet, and we appreciate your patience during this incident.
Posted Sep 24, 2025 - 16:36 UTC
Monitoring
We have implemented a fix for this issue.
We are closely monitoring to ensure the issue has been resolved and everything is working as expected. Please bear with us while we get back on our feet, and we appreciate your patience during this incident.
Posted Sep 24, 2025 - 15:37 UTC
Identified
We have identified an issue in our EU region that is negatively impacting the document report TaT. A fix has been implemented, and we are currently monitoring its effectiveness.
Posted Sep 24, 2025 - 14:57 UTC
This incident affected: Europe (onfido.com) (Document Verification).